SMS Servant - Übersicht

SMS Servant - Überblick

Diese Online-Hilfe bietet Ihnen Unterstützung bei Ihrer Arbeit mit dem SMS Servant. Mit den Pfeilen rechts oben blättern Sie von Seite zu Seite. Oder wählen Sie das gesuchte Thema aus dem Verzeichnis links. Mit dem Button [image] auf den Dialogfeldern rufen Sie die dazugehörige Hilfeseite direkt auf.

SMS Servant ist Shareware. Er kann 30 Tage lang getestet werden. Danach ist eine Registrierung erforderlich.

Diese Online Hilfe ist noch in Arbeit und wird in einer der nächsten Versionen des SMS Servants vervollständigt.

Mit dem SMS Servant können Sie:

  • SMS senden über das Tray Icon

  • SMS senden in der Kommando Zeile
  • SMS senden mit Outlook
  • SMS empfangen
  • empfangen SMS im Outlook Posteingang anzeigen lassen
  • empfangen SMS im Lotus Notes Posteingang anzeigen lassen
  • Ihrem PC per SMS fernsteuern

Der SMS Servant ist ein kleines Tray Icon in der Taskbar:

Hinweis: wenn der Mobile Master Agent ebenfalls gestartet wurde, so ist diese auch über dieses Tray Icon zu erreichen

Klicken Sie mit der rechten Maustaste auf das Symbol um das Menü anzuzeigen:

Hinweis: wenn der Mobile Master Agent ebenfalls geladen ist, so werden die Menüpunkte hier ebenfall mit aufgelistet.

Neue SMS: das Dialogfeld zum Erstellen und Senden einer SMS wird aufgerufen

SMS Servant aktivieren: wenn aktiviert werden vom angeschlossenem Handy die SMS eingelesen (alle x Sekunden)

SMS jetzt einlesen: es werden die SMS vom Handy eingelesen (nützlich, wenn z.B. ein großes Intervall eingestellt wurde)

SMS Liste anzeigen: Es wird die Liste mit alle bereits gesendeten und empfangen SMS angezeigt

Einstellungen: Es wird das Dialogfeld für die Einstellungen angezeigt

Der SMS Servant ist in den Mobile Master Agent integriert, d.h. wird der SMS Servant (SMSServ.exe) gestartet, so wird der Mobile Master Agent (MMAgent.exe) gestartet.

SMS Servant und der Mobile Master Agent teilen sich das gleiche Tray Icon, die beiden Anwendungen können aber getrennt voneinander gestartet werden. Je nachdem ob der SMS Servant oder der Mobile Master Agent oder beide gestartet sind, enthält das Menü des Tray Icon unterschiedliche Einträge.

Bedeutung des Tray Icons:

Mobile Master Agent geladen
SMS Servant geladen
Es wird nach einem Handy gesucht
Keine Verbindung zum Handy oder andere Fehler
Verbindung zum Handy


SMS Servant - Bestellen und Registrieren

Bestellen und Registrieren

Haben Sie sich entschieden, SMS Servant uneingeschränkt zu nutzen und zu registrieren, so können Sie dies Online über eine sichere Verbindung erledigen. Es werden alle weit verbreiteten Kreditkarten, Schecks und Banküberweisungen akzeptiert.

Bestellen Sie bequem Online und Sie erhalten Ihre Registrierung innerhalb kurzer Zeit (normalerweise erhalten Sie Ihre Lizenz-Datei innerhalb Minuten bis Stunden bei Kreditkartenzahlung):

SMS Servant €11,90 Jetzt kaufen

Bestellen Sie SMS Servant zusammen mit Mobile Master so erhalten Sie bis zu 8€ Rabatt:

SMS Servant + Mobile Master Light | €14,90 statt €21,80 | Jetzt kaufen
SMS Servant + Mobile Master Standard | €21,90 statt €29,80 | Jetzt kaufen
SMS Servant + Mobile Master Professional | €29,90 statt €37,80 | Jetzt kaufen

Sollten die Buttons oben nicht funktionieren, bitte über die Homepage (http://www.smsservant.de/register.htm) bestellen.
Preise inkl. 16% Mwst.

= sichere Verbindung

Updates sind in der Regel kostenlos. Wenn nicht, sind sie besonders gekennzeichnet.


SMS Servant - Einstellungen

Einstellungen

Optionen

Legen Sie hier fest, ob der SMS Servant (und/oder) der Mobile Master Agent beim Windows Login automatisch gestartet werden soll.

Tray Icon:

Bei Links Klick: legen Sie fest, was bei einem Links Klick auf das Tray Icon passieren soll.
Bei Doppelklick: legen Sie fest, was bei einem Links Klick auf das Tray Icon passieren soll.
Bei eine Recht Klick wird immer das Menü angezeigt.

Status Fenster anzeigen: aktivieren Sie diese Option, und es wird recht unten auf dem Bildschirm ein Status Fenster eingeblendet wenn SMS ausgelesen oder gesendet werden.

SMS Servant

Schnittstelle

Befehle und Ereignisse

SMS Servant aktivieren: aktivieren Sie diese Option, damit der SMS Servant SMS vom angeschlossenen Handy ausliest.

Alle ... Sekunden...: Legen Sie hier das Intervall fest, in dem SMS vom Handy ausgelesen werden sollen. Je häufiger SMS ausgelesen werden, desto schneller wird der Akku im Handy leer, vor allem bei Bluetooth oder Infrarot Verbindung.

Alle SMS einlesen: wählen Sie diese Option, wenn auch bereits am Handy gelesene SMS eingelesen werden sollen

Nur neue SMS einlesen: wählen Sie diese Option, wenn nur ungelesene SMS eingelesen werden sollen

Empfangene SMS:

löschen (im Handy): die ausgelesenen SMS werden im Handy gelöscht.

speichern in: geben Sie hier die Datei an, in der die eingelesenen SMS gespeichert werden sollen.

In Outlook im Posteingang anzeigen: aktivieren Sie diese Option, damit neue SMS in Ihrem Outlook Postfach angezeigt werden. (siehe auch Outlook AddIn)

In Lotus Notes im Posteingang anzeigen: aktivieren Sie diese Option, damit neue SMS in Ihrem Lotus Notes Postfach angezeigt werden.

Gesendete SMS:

speichern in: geben Sie hier die Datei an, in der die gesendeten SMS gespeichert werden sollen.


SMS Servant - Einstellungen Schnittstelle

Einstellungen serielle Schnittstelle

Serieller Port

Legen Sie hier den Port fest, an dem Ihr Handy angeschlossen ist.

Wählen Sie automatisch, so durch sucht der SMS Servant alle Ports bis ein Handy gefunden wird.

Baudrate

Stellen Sie die Baudrate ein (meist 115200).

RTS Enable

Wenn es Problem gibt, diese Einstellung ändern.

Pause zw...

Wenn es Problem gibt, diesen Wert auf 1000 erhöhen.


SMS Servant - SMS senden

neue SMS erstellen und senden

Um eine neue SMS zu erstellen und zu senden, klicken Sie mit der rechten Maustaste auf das SMS Servant TRay Icon und wählen 'neue SMS'.

An:

In das Feld neben der Schaltfläche wird die Telefon-Nummer des Empfängers eingetragen. Die Schaltfläche selbst öffnet eine Liste mit den im Handy gespeicherten Nummern. Ein Doppelklick auf den Namen überträgt die Nummer. Ist die Liste leer oder soll sie aktualisiert werden, klicken Sie auf 'Nummern neu einlesen'.

SMS senden

Die SMS wird in die Warteschlange der zu sendenden SMS eingereiht. Innerhalb von Sekunden sollte das Status Fenster des SMS Servants erscheinen, das das Senden der SMS anzeigt.

SMS speichern

Die SMS wird im Handy und im SMS Center gespeichert.

Senden von SMS mit Outlook.

Senden von SMS per Kommandozeile:

sms {empfängernummer} {text}


SMS Servant - das Outlook AddIn

Das Outlook AddIn

Das Outlook AddIn dient zum Senden von SMS in Outlook.

SMS Senden:

Wenn das AddIn installiert ist, so kann über die Schaltfläche [image] oder über das Menü DateiðNeuðSMS eine neue SMS erstellt werden. Siehe auch neue SMS.

Hinweis: in der Kontakte-Ansicht in Outlook, wählen Sie den Kontakt, an den Sie eine SMS senden wollen und klicken dann auf [image].

Oder Klicken Sie auf Antworten, wenn Sie eine SMS im Posteingang markiert haben.

SMS Empfangen:

Um empfangene SMS im Outlook Posteingang anzuzeigen ist das AddIn nicht notwendig.

Stellen Sie aber sicher, dass in den SMS Servant Einstellungen die Option 'In Outlook im Posteingang anzeigen' aktiviert ist.

Installation und Deinstallation des AddIns:

Um in Outlook selbst das AddIn hinzuzufügen oder zu entfernen, in Outlook 2000/2002 folgende Schritte durchführen:
Extras ðOptionen ðWeitere ðErweiterte Optionen ðCOM-Add-Ins... .
Hier kann dann das AddIn entfernt oder hinzugefügt werden (Datei SMSOutlookAddIn.dll).


SMS Servant - PC per SMS fernsteuern

PC per SMS fernsteuern

PC per SMS fernsteuern

Empfängt das Handy eine SMS mit einem definiertem Inhalt, so kann der SMS daraufhin Skripte ausführen.
Beispielsweise wird eine SMS mit dem Inhalt 'pc aus' empfangen, so wird der PC heruntergefahren.

Es können im einer SMS mehrere SMS Befehle gesendet werden. Diese müssen mit : getrennt werden.

Befehle

Hier werden die definierten SMS Befehle aufgelistet.

Neuen Befehl hinzugügen, Alt+N
markierten Befehl editieren, Alt+E
markierten Befehl löschen, Alt+D
weitere Einstellungen

Um einen neuen SMS Befehl zu erstellen, klicken Sie auf [image] oder drücken Alt+N.
Es erscheint das Fenster zum definieren der SMS Befehle.


Optionen für Befehle

Befehle in SMS von allen Absendern akzeptieren

Enthält eine empfangene SMS eine oder mehrere Befehle, so wird/werden diese ausgeführt, egal wer die SMS gesendet aht.

Befehle in SMS akzeptieren nur von:

Geben sie hier eine (oder mehrere, getrennt mit ;) Telefonnummer(n) an, von der SMS Befehle akzeptiert werden.

Trennzeichen für Befehle:

Geben Sie hier ein Zeichen an, dass als Trennzeichen zwischen SMS Befehlen dient, wenn mehrere SMS Befehle in einer SMS gesendet werden.

Bestätigungen:

Jeden Befehl per SMS bestätigen:
Aktivieren Sie diese Option um eine Bestätigungs-SMS zu erhalten, wenn das dem SMS Befehl zugeordnete Skript ausgeführt wurde.

Bestätigung an Sender schicken:

Aktivieren Sie die Option, damit die Bestätigung an den Sender des SMS Befehls geschickt wird

Bestätigung senden an:

Aktivieren Sie die Option und geben eine Nummer, an die Bestätigung geschickt wird.


SMS Befehl erstellen, editieren

Name des Skripts: Nur zur Beschreibung, wird sonst nicht verwendet.

SMS Befehl: Text der per SMS geschickt wird, und dann vom SMS Servant empfangen wird, und schliesslich die das definierte Skript ausführt. Z.B. im obigen Beispiel bewirkt das Senden eine SMS mit dem Inhalt 'pc aus', dass der Rechner heruntergefahren wird.

Befehle: Hier sehen Sie eine Liste der verfügbaren Befehle. Markieren Sie einen und klicken auf [image] um diesem dem Skript hinzuzufügen. Je nach Befehl ist ein Parameter einzugeben.

Delay:

fügt eine definierbare Verzögerung in das Skript ein.

Fenster aktivieren:

es wird versucht das angebende Fenster zu aktivieren (Fokus setzen). Es kann auch nur ein Teil des Fensternamens angegeben werden.

Programm starten/Command Line:

Geben Sie hier ein Programm ein, dass gestartet werden soll, oder eine Kommandzeile, die ausgeführt werden soll.

Tastenanschläge senden:

Hier können Sie die Tasten angeben, die Sie sonst manuell drücken würden.
Details über Tastencodes.

Windows beenden:

Windows wird heruntergefahren. Es kann optional eine Verzögerung angegeben werden.

Windows neu starten:

Windows wird neu gestartet. Es kann optional eine Verzögerung angegeben werden.

markierten Befehl zum Skript hinzufügen
markierten Befehl (im Skript) editieren
markierten Befehl (im Skript) löschen
markierten Befehl (im Skript) nach oben verschieben
markierten Befehl (im Skript) nach unten verschieben


Tastaturscodes

Tastencodes

Übersicht über die Tastencodes für den Skript-Befehl Tastenanschlägen senden:

Für Alt + F4 geben Sie z.B.

%{F4}

ein.

Um eine Taste mehrmals zu Drücken, lautet die Syntax {taste n}, also z.B. {a 10} um 10 mal a zu drücken.

+(abc) bewirkt, dass die Umschalttaste zusammen mit abc betätigt wird, also ABC.

+abc hingegen ergibt Abc.

Taste | Code
UMSCHALT | +
STRG | ^
ALT | %

Taste | Code
RÜCKTASTE | {BACKSPACE}, {BS} oder {BKSP}
PAUSE | {BREAK}
FESTSTELLTASTE | {CAPSLOCK}
ENTF | {DELETE} oder {DEL}
NACH-UNTEN | {DOWN}
ENDE | {END}
EINGABETASTE | {ENTER}oder ~
ESC | {ESC}
HILFE | {HELP}
POS 1 | {HOME}
EINFG | {INSERT} oder {INS}
NACH-LINKS | {LEFT}
NUM-FESTSTELL | {NUMLOCK}
BILD-AB | {PGDN}
BILD-AUF | {PGUP}
DRUCK | {PRTSC}
NACH-RECHTS | {RIGHT}
ROLLEN-FESTSTELL | {SCROLLLOCK}
TAB | {TAB}
NACH-OBEN | {UP}
F1 | {F1}
F2 | {F2}
F3 | {F3}
F4 | {F4}
F5 | {F5}
F6 | {F6}
F7 | {F7}
F8 | {F8}
F9 | {F9}
F10 | {F10}
F11 | {F11}
F12 | {F12}
F13 | {F13}
F14 | {F14}
F15 | {F15}
F16 | {F16}


SMS Servant - Kommandozeilen Parameter

Kommando Zeile

Sie können SMS in der Kommando Zeile (DOS Box) senden, und somit in Ihre Batch und Script Dateien einbauen.

Zum Senden einer SMS die der Befehl SMS:

SMS number message

e.g.

SMS +49123456789 Hallo hier eine SMS von mir!

SMS.exe ist ein kleines Program, dass bei Installation im Windows-Verzeichnis installiert wird und die übergebenen Parameter an dem SMS Servant übergibt, der dann die SMS sendet. Es gibt keinen Rückgangewert, ob die SMS gesendet wurde, da SMS.exe bereits beendet wurde, wenn die SMS gesendet wird.

Kommandozeilen-Optionen vom SMSServ.exe:

SMSServ.exe number message | /d debugfile

ohne Paramter wird der SMS Servant gestartet und das Tray Icon installiert.

Mit dem Schalter /d filename wird ein Dateiname übergeben. In diese Datei wird dann Debug Information geschrieben.

Bei Abstürtzen bitte dieses Datei an senden.

Kommandozeilen-Optionen vom MMAgent.exe:

MMAgent [ new ] [ smsservant | both ]

MMAgent startet den Mobile Master Agent

MMAgent smsservant startet den SMS Servant

MMAgent both startet den Mobile Master Agent und den SMS Servant

mit dem Parameter new wird eine neue Instanz gestartet, es kann also z.B. mit

MMAgent

der Agent gestartet werden und mit

MMAgent new smsservant

dann der SMS Servant als neuer Prozess und mit eigenem Tray Icon. Es haben dann also der Agent und der SMS Servant jeweils ein eigenes Tray Icon.

Achtung: Man kann damit auch mehrfach den SMS Servant starten. Diese greifen aber alle auf die gleichen Einstellungen zu, so dass man damit nicht 2 Handys, die gelichzeitig am PC angeschlossen sind nutzen kann. Dies kommt evtl. in einer künftigen Version.


SMS Liste

PC per SMS fernsteuern